Poster une réponse  Créer un sujet 
Pages (3): « Première < Précédente 1 [2] 3 Suivante > Dernière »
Précautions d'utilisation d'un NAS
Auteur Message
Jean-Louis P
Posting Freak
*****


Messages : 988
Groupe : Enregistré
Inscription : 11/10/2011
Statut : Hors ligne
Message : #11
RE: Précautions d'utilisation d'un NAS

Bonsoir Joël

Merci beaucoup pour cette contribution. Je l'ai appliquée aujourd'hui en passant du Beagle Bone Black au RPi B+, puisque la version que tu as indiquée n'est pas encore dispo sur le BBB. Malheureusement les plocs sont toujours là...

J'ai alors essayé d'augmenter les deux paramètres
- Audio Buffer Size
- % Buffer vbefore play
mais j'ai l'impression que c'était encore pire.

Je n'ai pas réussi à utiliser le tcptrack en faisant un putty sur volumio, peux tu préciser comment tu te mets en mode terminal ?

Chose curieuse, lorsque j'écoute la radio sur internet depuis volumio je n'ai pas ce phénomène. Et dès que je tente de la plus haute définition c'est encore pire.

J'avoue que j'y perds mon latin...

J'avais tenté à un moment de regarder des choses sur le driver à propos d'une erreur "FIQ Reported NYET" http://archphile.org/howto/troubleshooti...nd-clicks

mais il faudrait que je reprenne, c'est compliqué. Une expérience de ton côté ?

Ce message a été modifié le: 08/01/2018 02:11:31 par Jean-Louis P.

08/01/2018 02:01:46
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Jean-Louis P
Posting Freak
*****


Messages : 988
Groupe : Enregistré
Inscription : 11/10/2011
Statut : Hors ligne
Message : #12
RE: Précautions d'utilisation d'un NAS

Sinon, j'essaierai de passer un I2S direct du RPI vers mon filtre Najda sans passer par la carte USB XMOS mais ça implique une liaison très courte et pratiquement de mettre le RPI dans le Najda... et l'I2S du RPI n'a pas l'air d'être la panacée http://www.dimdim.gr/2014/12/the-rasberr...rough-i2s/

ou de commander un nouveau RPI 3...

Dur, dur, la démat parfois

08/01/2018 02:11:42
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Dominique-Tanguy
Posting Freak
*****


Messages : 5 368
Groupe : MELAUDIA.membre
Inscription : 23/08/2009
Statut : Hors ligne
Message : #13
RE: Précautions d'utilisation d'un NAS

Bonjour Jean-Louis,

Je te suggère un essai simple. Choisi un morceau haute rėsolution avec lequel tu rencontres des problèmes de lecture. Copie le sur une clė USB. Insère la clé dans un des ports USB du RPI3 et lance la lecture depuis la clé.

Reviens vers nous pour nous ire si tu entends encore des plocs.

Dominique T


Cordialement,

Dominique T

http://unepassionaudiophile.fr/
08/01/2018 09:46:48
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
jsilvestre
Senior Member
****


Messages : 529
Groupe : Enregistré
Inscription : 13/01/2014
Statut : Hors ligne
Message : #14
RE: Précautions d'utilisation d'un NAS

Bonjour Jean-Louis

si j'ai bien tout suivi tu as les mêmes soucis de plocs avec les 3 systèmes et sur les deux cartes?
Dans ce cas effectivement le dénominateur commun est bien le NAS.

Les disques durs sont des WD green, hors pour afficher des consommations d’énergie plus basses que les concurrents ils ont eu une super mauvaise idée, ranger les têtes de lecture après 8 secondes d'inactivité mettant le disque en semi-veille. Sortir de cet état prend du temps, les données arrivent en retard, risque de plocs.
De plus ranger les têtes est une opération mécanique, la mécanique ça s'use surtout quand l'opération est répétée plus d'un million de fois!
J'ai trouvé de quoi diagnostiquer simplement. La ligne en question est la 193 Load cycles count. Dans l'exemple les têtes ont étés rangées 1.5 million de fois!

https://superuser.com/questions/713155/s...rors-shown

Si le problème est bien là, reste à trouver comment le résoudre simplement.

Joël

08/01/2018 15:24:04
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
lenco073
Member
***


Messages : 59
Groupe : Enregistré
Inscription : 14/11/2008
Statut : Hors ligne
Message : #15
RE: Précautions d'utilisation d'un NAS

Bonjour à tous,

Et il y a deux ans ils ont eu une autre (mauvaise) idée chez Western Digital, le Green s'appelle le Blue,

Mais est ce que les disques ont la même technologie !

Ce message a été modifié le: 08/01/2018 19:20:57 par lenco073.

08/01/2018 19:20:16
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Jean-Louis P
Posting Freak
*****


Messages : 988
Groupe : Enregistré
Inscription : 11/10/2011
Statut : Hors ligne
Message : #16
RE: Précautions d'utilisation d'un NAS

Merci Joël

Après vérification, c’est un fait que WD recommande les disque de type RED pour les NAS et les applications RAID... c’etait évidemment pas marqué sur les boîtes quand j’ai acheté les miens. Les Green ou Blue maintenant sont destinés à des PC desktop sous Windows ou des Mac. Merci WD!
Ils ont bien un utilitaire dédié aux premiers Green sortis WD1000FYPS-01ZKB0, WD7500AYPS-01ZKB0, WD7501AYPS-01ZKB0 mais pas aux suivants de plus grande capacité pour lesquels le pb a peut être été réglé autrement.

J’ai regardé aussi le compteur Load Cycle Count que tu mentionnes mais je n’ai « que » 24 000 unités , peut être en un an, soit environ 22/h sur 3h de Musique par jour, donc bien inférieur à mes plops qui sont tous les quelques secondes.

J’ai posté le log mpd sur le site Volumio à tout hasard, s’il y a un expert mpd parmis nous ... https://volumio.org/forum/geting-crazy-w...t8539.html.

Je vais essayer aussi la manip de Dominique T avec une carte mémoire j’avais essayé avec un disque externe mais les plops’ etaient toujours là.

Les mêmes morceaux passés sur mon portable Windows passent nickel.
Quand je passe la radio internet pas de pb non plus.
Par contre une particularité, j’alimente ma carte usb WaveIO par le câble USB du RPI, dont la puissance est limitée à 0,6 A. Est ce que ça pourrait générer des instabilités ? Il faudrait que je teste une alim externe... mais il existe aussi un paramètre dans /boot/config.txt max_usb_current=1
Je viens de vérifier il est recommandé 5V 0,5 A
Bonne soirée

Ce message a été modifié le: 09/01/2018 00:33:27 par Jean-Louis P.

09/01/2018 00:17:45
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Jean-Louis P
Posting Freak
*****


Messages : 988
Groupe : Enregistré
Inscription : 11/10/2011
Statut : Hors ligne
Message : #17
RE: Précautions d'utilisation d'un NAS

Jean-Louis P a écrit :
Par contre une particularité, j’alimente ma carte usb WaveIO par le câble USB du RPI, dont la puissance est limitée à 0,6 A. Est ce que ça pourrait générer des instabilités ? Il faudrait que je teste une alim externe... mais il existe aussi un paramètre dans /boot/config.txt max_usb_current=1
Je viens de vérifier il est recommandé 5V 0,5 A


Zut, le paramètre est par défaut en forcé donc le RPI doit sortir 1,2 A max ...

Ce message a été modifié le: 09/01/2018 11:57:22 par Jean-Louis P.

09/01/2018 11:56:16
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Jean-Louis P
Posting Freak
*****


Messages : 988
Groupe : Enregistré
Inscription : 11/10/2011
Statut : Hors ligne
Message : #18
RE: Précautions d'utilisation d'un NAS

Dominique-Tanguy a écrit :
Bonjour Jean-Louis,

Je te suggère un essai simple. Choisi un morceau haute rėsolution avec lequel tu rencontres des problèmes de lecture. Copie le sur une clė USB. Insère la clé dans un des ports USB du RPI3 et lance la lecture depuis la clé.

Reviens vers nous pour nous ire si tu entends encore des plocs.

Dominique T

Bonjour Dominique Tanguy
Essai fait avec clé USB ça pétille toujours toutes les quelques secondes
Merci de la suggestion

09/01/2018 15:10:03
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Dominique-Tanguy
Posting Freak
*****


Messages : 5 368
Groupe : MELAUDIA.membre
Inscription : 23/08/2009
Statut : Hors ligne
Message : #19
RE: Précautions d'utilisation d'un NAS

Très bien, donc ce n'est pas le NAS...

Il faut regarder du côté de l'alimentation. Pour l'alimentation externe tu peux acheter un duplicateur de port auto alimenté pour quelques euros. C'est ce que je conseille quand on connecte un disque USB au RPI.

   

Dominique T


Cordialement,

Dominique T

http://unepassionaudiophile.fr/
09/01/2018 18:52:51
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Jean-Louis P
Posting Freak
*****


Messages : 988
Groupe : Enregistré
Inscription : 11/10/2011
Statut : Hors ligne
Message : #20
RE: Précautions d'utilisation d'un NAS

J'avais essayé avec un réplicateur, ça n'avait rien changé.

J'ai trouvé entre temps un incident très similaire sur lequel Volumio s'est manifesté https://github.com/raspberrypi/linux/issues/2215
mais c'est très technique, on est carrément dans le noyau Linux sur architecture ARM, même les développeurs sont un peu dans la choucroute.

Ce qui serait intéressant c'est que quelqu'un ayant une carte USB WaveIO et un RPI essaie avec Volumio dans la même configuration que moi.

Jean-Louis

09/01/2018 19:19:11
Trouver tous les messages de cet utilisateur Citer ce message dans une réponse
Poster une réponse  Créer un sujet 

Voir une version imprimable
Envoyer ce sujet à un ami
S'abonner au sujet | Ajouter le sujet aux favoris

Aller à :